×

info

Dear guests,
You are currently on the old forum we kept as a knowledge base. You will find the new community forum here
Welcome, Guest
Username: Password: Remember me
Keyword

TOPIC: Introtext embedded component tag does not execute, body of the article works fine, how to resolve?

Introtext embedded component tag does not execute, body of the article works fine, how to resolve? 3 years 8 months ago #105357

  • Anonymous user
  • Stuckshutter's Avatar
  • Posts: 128
  • Karma: 0
Hi and thanks for a super flexible component, it's amazingly flexible.
We ran into an issue getting a tag that Tabulizer uses to execute in the introtext.
It's pretty simple, the tag we create looks like this:
[rssfeedstyle1:http://www.somerssfeed.com]
The tag executes in the body text but not in the emailed version of the newsletter.
Can you recommend an approach to get the tag to execute in the emailed version of the newsletter?
Thanks!
Please log in to post a reply

Introtext embedded component tag does not execute, body of the article works fine, how to resolve? 3 years 8 months ago #105379

  • Dax
  • Dax's Avatar
  • Posts: 6423
  • Karma: 227
Hi,

You can turn On the "AcyMailing : trigger Joomla Content plugins" plugin to execute the content/system plugins in the inserted articles.
Note that we don't turn it On by default as some content plugins may do crappy things, so if you notice something strange, you should disable this plugin.

Jeremy
-AcyMailing developer-
This email address is being protected from spambots. You need JavaScript enabled to view it.

I helped you? The best way to thank me is to post a review on the JED :laugh:

Do not hesitate to illustrate your messages with screenshots, I love images :)
Always consult our tutorials before asking a question on our forum, the answer is surely there ;)

Hey look at our Video tutorials, It's really helpful to understand how Acy works!
Please log in to post a reply

Introtext embedded component tag does not execute, body of the article works fine, how to resolve? 3 years 8 months ago #105403

  • Anonymous user
  • Stuckshutter's Avatar
  • Posts: 128
  • Karma: 0
Hi Jeremy,
The Trigger Joomla Plugin was activated since we use it for other content/system components too.
Do you have any other thoughts that might be helpful?
Thanks
Please log in to post a reply

Introtext embedded component tag does not execute, body of the article works fine, how to resolve? 3 years 8 months ago #105425

  • Dax
  • Dax's Avatar
  • Posts: 6423
  • Karma: 227
Well if it's already activated, I don't know why your plugin doesn't replace the [rssfeedstyle1:...] elements.
Note that we have a plugin to insert elements of an RSS feed, it could e useful: www.acyba.com/acymailing/plugins.html#newsfeeds

If you really need the [rssfeedstyle1:...] elements to be replaced, you will have to use your own PHP code in a custom layout: www.acyba.com/acymailing/78-acymailing-p...ontent.html#template
-AcyMailing developer-
This email address is being protected from spambots. You need JavaScript enabled to view it.

I helped you? The best way to thank me is to post a review on the JED :laugh:

Do not hesitate to illustrate your messages with screenshots, I love images :)
Always consult our tutorials before asking a question on our forum, the answer is surely there ;)

Hey look at our Video tutorials, It's really helpful to understand how Acy works!
Please log in to post a reply

Introtext embedded component tag does not execute, body of the article works fine, how to resolve? 3 years 8 months ago #105435

  • Anonymous user
  • Stuckshutter's Avatar
  • Posts: 128
  • Karma: 0
Hi Dax,
Thanks for the suggestions. We looked at the newsfeed plugin but the feed url varies by listowner as they can insert any url to any newsfeed in their articles.
I imagine the display issue is when the replacement code is inserted as newsletters are being sent. Probably after the processing of the tags. Works fine on the website, only the email version of the newsletter has the issue.
I'll check in with RokCandy to see if I can find when their plugin runs.
Appreciate your help.
Please log in to post a reply
Time to create page: 0.154 seconds
Powered by Kunena Forum