×

info

Dear guests,
You are currently on the old forum we kept as a knowledge base. You will find the new community forum here
Welcome, Guest
Username: Password: Remember me
Keyword

TOPIC: Joomla 3.x multilingual with double opt-in : avoid 404 error on user mails

Joomla 3.x multilingual with double opt-in : avoid 404 error on user mails 6 years 6 months ago #62465

  • Anonymous user
  • siwayjoomla's Avatar
  • Posts: 7
  • Karma: 1
For this configuration :
  • joomla 3.x
  • multilingual website
  • AcyMailing with double Opt-in

You need to create a technical link set as followed :
  • Menu Item Type = Acymailing / User : subscribe/modify your subscription
  • Language = ALL
  • Published

And to set it in the Acymailing Configuration :
[Acymailing / Configuration / Interface / Menu / Menu Linked to AcyMailing]

This will avoid that the links sent to the user retrun a page with 404 error.

This solution has been tested and approved with Adrien from Acymailing.
Nicolas
Please log in to post a reply

Re: Joomla 3.x multilingual with double opt-in : avoid 404 error on user mails 6 years 6 months ago #62466

  • Anonymous user
  • Adrien's Avatar
  • Posts: 20233
  • Karma: 681
Thank you Nicolas for sharing the result.
Please have a look at our official documentation before posting a new message!

Do you like AcyMailing? We love your reviews!
We would appreciate if you could take 5 minutes to post a review on the Joomla! Extensions Directory.
We answered one of your question? Well, it's the best way to thank us!
Please log in to post a reply

Re: Joomla 3.x multilingual with double opt-in : avoid 404 error on user mails 3 years 8 months ago #105607

  • Anonymous user
  • jvstratum's Avatar
  • Posts: 7
  • Karma: 0
Hi,

I've found the solutuion in your forum thread #62465. I have created a hidden menu and now things are working and the article's item-id is not added anymore.

However, there is one behaviour I don't understand. When you create a newsletter and set the language to Dutch, the language tag (/nl) is removed from the url and because of this setting the parameter &lang=nl is added. This causes a 404.

When no language is selected in the newsletter the language tag is present in the url and everything works fine.

Do you have any thoughts on this?
Please log in to post a reply

Re: Joomla 3.x multilingual with double opt-in : avoid 404 error on user mails 3 years 8 months ago #105618

  • Alexandre
  • Alexandre's Avatar
  • Posts: 2462
  • Karma: 67
Hi,

Our next version which will be out next week will solve this issue so feel free to download it and install it as soon as it is available ;)
Please log in to post a reply

Re: Joomla 3.x multilingual with double opt-in : avoid 404 error on user mails 3 years 8 months ago #105628

  • Anonymous user
  • jvstratum's Avatar
  • Posts: 7
  • Karma: 0
Great!

Thank you for your help!
Please log in to post a reply
Time to create page: 0.067 seconds
Powered by Kunena Forum