×

info

Dear guests,
You are currently on the old forum we kept as a knowledge base. You will find the new community forum here
Welcome, Guest
Username: Password: Remember me
Keyword

TOPIC: CRON on my hosting account not sending

CRON on my hosting account not sending 10 years 8 months ago #3041

  • Anonymous user
  • CoachJohn's Avatar
  • Posts: 9
  • Karma: 0
Hi, can anyone please help?

I have set up a CRON on my Hostgator account and I have set it to send me an email each time it is called.

I Have items in the queue that are now over due being sent.

Even though I get the emails from the CRON on my server nothing is being sent form AcyMailer.

The email from the CRON says


Mailing Lists
Newsletters
Receive our latest news


In the AcyMailer configuration, I have set the CROn to log actions and email me. Neither of these is occurring.

So I know the CRON on the Hostgator account runs but does not trigger the AcyMailer to send.

If I paste the CRON URL directly into a browser it triggers the emails correctly and all expected emails arrive.

So Anyone and ideas why the CRON on the server does not correctly trigger AcyMailer, and assuming it is a server problem what do I ask the Hostgator support. They say as the CRON runs it is not their problem.
Please log in to post a reply

Re: CRON on my hosting account not sending 10 years 8 months ago #3043

  • Anonymous user
  • robert's Avatar
  • Posts: 138
  • Karma: 15
Hi,

It could be related to the way you wrote your cron task. For example, suppose that you have some htaccess code which directs the people typing youwebsite.com to www.yourwebsite.com and that you cron task uses the command below:
wget yourwebsite.com/...
If you don't add the -r to wget, it won't follow the redirection set in place by your htaccess and it will just stop here. But if you test with your browser, it will follow the redirection and display you the correct page.

that's just an example you what could be happening. If you could write the command you're using for your cron that would probably help us understand better your problem.

Regards
With HikaShop, create your online Joomla shop easily.
Please log in to post a reply

Re: CRON on my hosting account not sending 10 years 8 months ago #3046

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
That also may be due to the & character in our cron url.
You should try the solution written on this post which corresponds to your report:
www.acyba.com/support/forum/2-bug-report...-processed.html#1377
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3070

  • Anonymous user
  • CoachJohn's Avatar
  • Posts: 9
  • Karma: 0
Hi, Yes the problem is the & and Hostgator support eventually said they do not support custom CRONs.

It tried creating a script to call the URL. However, I am getting an internal server error in the CRON report.

My ability to work with PHP is well below what I need to take this forward. Have you any ideas how I can move forward?

Any other PHP script to call the acymailer corn?
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3073

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Don't you want to use our own cron system?
That way you won't have to bother with this issue.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3074

  • Anonymous user
  • CoachJohn's Avatar
  • Posts: 9
  • Karma: 0
And your system works well.

The client is very keen to have the CRON running on their own server.

If that can be possible I would be most grateful. However, if it is not I will be able to persuade them.
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3077

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Could you please tell me more about the error you get for the Hostgator cron?
And which code did you add to your external file? (so I can quickly check it)
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3081

  • Anonymous user
  • CoachJohn's Avatar
  • Posts: 9
  • Karma: 0
error message a very unhelpful
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, This email address is being protected from spambots. You need JavaScript enabled to view it. and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

I am not sure how to get the error logs
Last Edit: 10 years 8 months ago by Anonymous user.
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3082

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Indeed, not very useful...

I mean the script you tried to use to call the cron, not only your cron url but the entire file you used.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3083

  • Anonymous user
  • CoachJohn's Avatar
  • Posts: 9
  • Karma: 0
Oops sorry

<?php
header("Location: www.newmlmsupportforum.com/index2.php?op...gtask=cron&Itemid=51 ");
exit();
?>
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3085

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Yes, in your case this code should indeed do the job:
<?php
header("Location: http://www.newmlmsupportforum.com/index2.php?option=com_acymailing&gtask=cron&Itemid=51");
exit();
?>

(I re-write it here to make sure you didn't add spaces or things like that in the url as I could not see it properly on your previous post)


First we will make sure this file is triggered properly.
Could you please write this code in your file instead of the previous one:
<?php
mail('youremail@yourdomain.com' ,'Test cron message', 'this is just a test');
?>
If you receive an e-mail every 15 minutes (or something else depending on the way you configured your cron), that means your cron task is working as it should and is able to trigger this file properly and so that means it's really the code written inside the file which does not work.
If not, that means the issue is that your cron system can not even trigger this php file and so the issue is probably in the way you wrote your cron on your hosting interface.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3093

  • Anonymous user
  • CoachJohn's Avatar
  • Posts: 9
  • Karma: 0
We get internal server error again
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3094

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
So the problem is that the file can not be triggered.

What command did you wrote in your cron interface?
Can you add a screenshot on your next post?
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3095

  • Anonymous user
  • CoachJohn's Avatar
  • Posts: 9
  • Karma: 0
Cron call
/usr/bin/curl www.newmlmsupportforum.com/acymail.php
can I email screen shot as it contains other bits that are back end details?
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3096

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
The file you are trying to trigger contains an error as I get the internal server error even when accessing it from my browser so it's not a cron issue for now.
We must be able to trigger this file from the browser:
www.newmlmsupportforum.com/acymail.php

So it's either a mistake in the file itself or maybe a problem of access rights.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Last Edit: 10 years 8 months ago by Anonymous user.
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3098

  • Anonymous user
  • CoachJohn's Avatar
  • Posts: 9
  • Karma: 0
<?php
mail('This email address is being protected from spambots. You need JavaScript enabled to view it.' ,'Test cron message', 'this is just a test');
?>
just these three lines in it
the file permissions are set to 664
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3100

  • Anonymous user
  • CoachJohn's Avatar
  • Posts: 9
  • Karma: 0
I am using SH404SEf so I turned it off and renamed .htaccess
no server error message, but no sign of an email being sent.
replaced the code with the call to acymailing cron and tried again, but it did not call the cron.

A step forwards of sort.
Please log in to post a reply

Re:CRON on my hosting account not sending 10 years 8 months ago #3102

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
It seems that the file is not triggered at all when I try to access it via my browser.
It's actually the same result as if I write
www.newmlmsupportforum.com/qfqsdfqsdfqsfd.php

The page reacts like if there were no file.
Are you sure you uploaded your file on this folder and it has the correct name?
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply
Time to create page: 0.067 seconds
Powered by Kunena Forum