×

info

Dear guests,
You are currently on the old forum we kept as a knowledge base. You will find the new community forum here
Welcome, Guest
Username: Password: Remember me
Keyword

TOPIC: "Please enable the Javascript to be able to subscribe"

"Please enable the Javascript to be able to subscribe" 10 years 8 months ago #2436

  • Anonymous user
  • sickline's Avatar
  • Posts: 3
  • Karma: 0
Hi,

I've just installed AcyMailing on my Joomla 1.5 CMS. When I try to subscribe to the newsletter I receive the following message: "Please enable the Javascript to be able to subscribe"

I've found older threads related to this topic, but I'm still not able to solve this problem. It would be nice if you're able to help me.

Any ideas?

Thanks and regards,
Mike
Last Edit: 10 years 8 months ago by Anonymous user.
Please log in to post a reply

Re:"Please enable the Javascript to be able to subscribe" 10 years 8 months ago #2439

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Hello Mike,

Your headers seems good.
Could you please add the url of your website so we can have a look at the module and tell you why you have such an error?
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:"Please enable the Javascript to be able to subscribe" 10 years 8 months ago #2444

  • Anonymous user
  • sickline's Avatar
  • Posts: 3
  • Karma: 0
Part of the message is hidden for the guests. Please log in or register to see it.
Last Edit: 10 years 8 months ago by Anonymous user.
Please log in to post a reply

Re:"Please enable the Javascript to be able to subscribe" 10 years 8 months ago #2446

  • Anonymous user
  • robert's Avatar
  • Posts: 138
  • Karma: 15
Hi,

If you try to access the url of the js file directly like this:
Part of the message is hidden for the guests. Please log in or register to see it.
you get a 404 error, meaning that the file is not found. This url is generated by your browser by appending the relative url of the js file, which is components/com_acymailing/js/acymailing_module.js to the base url you have setted in your header:
Part of the message is hidden for the guests. Please log in or register to see it.
Instead, the proper url should be:
Part of the message is hidden for the guests. Please log in or register to see it.
which works properly.
So I would say that you need to change the base url to :
Part of the message is hidden for the guests. Please log in or register to see it.
This problem is between the fact that you have SEF activated on your website, and the option $live_site you have set in your joomla configuration. Could you tell us what you have in this option in your configuration.php file ?
Maybe you could try to set in there the url of your website.
I see a lot of posts about this base url issue with SEF on joomla forums and this might solve the problem as explained there:
forum.joomla.org/viewtopic.php?p=1993926#p1993926

Regards
With HikaShop, create your online Joomla shop easily.
Please log in to post a reply

Re:"Please enable the Javascript to be able to subscribe" 10 years 8 months ago #2730

  • Anonymous user
  • sickline's Avatar
  • Posts: 3
  • Karma: 0
Thanks for your hint. It works perfectly fine now!
Please log in to post a reply

Location ? 10 years 8 months ago #3040

  • Anonymous user
  • thewebguy's Avatar
  • Posts: 7
  • Karma: 0
robert wrote:
Hi,

If you try to access the url of the js file directly like this:
Part of the message is hidden for the guests. Please log in or register to see it.
you get a 404 error, meaning that the file is not found. This url is generated by your browser by appending the relative url of the js file, which is components/com_acymailing/js/acymailing_module.js to the base url you have setted in your header:
Part of the message is hidden for the guests. Please log in or register to see it.
Instead, the proper url should be:
Part of the message is hidden for the guests. Please log in or register to see it.
which works properly.
So I would say that you need to change the base url to :
Part of the message is hidden for the guests. Please log in or register to see it.
This problem is between the fact that you have SEF activated on your website, and the option $live_site you have set in your joomla configuration. Could you tell us what you have in this option in your configuration.php file ?
Maybe you could try to set in there the url of your website.
I see a lot of posts about this base url issue with SEF on joomla forums and this might solve the problem as explained there:
forum.joomla.org/viewtopic.php?p=1993926#p1993926

Regards

Hi all,

This is my first post here so please be gentle !

I'm having the same problem as described in the other posts. I was just wondering which files I would need to alter in order to achieve the alteration described in the quote (above) & at what location the file can be found ?

Thank you in advance of any help or pointers provided - Ernie
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3042

  • Anonymous user
  • robert's Avatar
  • Posts: 138
  • Karma: 15
Hi,

The modification described is to be done in the file called configuration.php at the root of your website. That's the file where joomla stores your configuration which can be edited in your backend.

In this file, you can add a variable $live_site (if you already have it you can just change its line) like this:
var $live_site = 'yourwebsiteurl.com';
that will force your template to use the proper url in order to display the links.

Regards
With HikaShop, create your online Joomla shop easily.
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3045

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
If that does not solve your problem, please write on your next post your website url (where the AcyMailing module is displayed) so we can make sure you really have the same issue as sickline.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Last Edit: 10 years 8 months ago by Anonymous user.
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3051

  • Anonymous user
  • thewebguy's Avatar
  • Posts: 7
  • Karma: 0
Hi & thank you for your quick response,

I amended the configuration.php file but alas I still get the same issue, ie. the display of
  • Please enable the Javascript to be able to subscribe

Here is the Url of the site I'm developing (as requested from John) It's on my server at the moment for the duration of the development process & will be transfered to the live location when it's running well.

Part of the message is hidden for the guests. Please log in or register to see it.

Please note that I'm working on the site most of the time so hopefully me working wont interfere with anything that you're looking at ?

Regards, Ernie
Last Edit: 10 years 8 months ago by Anonymous user.
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3052

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
It was not the same problem as sickline.

The AcyMailing javascript file is not added at all in your template and that's why you get this error when you try to subscribe a user.

Is the tag <jdoc:include type="head" /> added to your template header?
This tag is required in any Joomla template so that Joomla components can load javascript files in the template.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3054

  • Anonymous user
  • thewebguy's Avatar
  • Posts: 7
  • Karma: 0
Is the tag <jdoc:include type="head" /> added to your template header?
This tag is required in any Joomla template so that Joomla components can load javascript files in the template.

In which file would I need to check if the code is there and if not place the code in ?
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3055

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
This code should be inserted between the <header> tags of your Joomla template so you can go on your Joomla template manager, then edit your template and click on the button "edit HTML".
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3057

  • Anonymous user
  • thewebguy's Avatar
  • Posts: 7
  • Karma: 0
Alas, the code is already there.
<head>
		<jdoc:include type="head" />
		<?php
		require(YOURBASEPATH . DS . "rt_utils.php");
		require(YOURBASEPATH . DS . "rt_head_includes.php");

	?>
	</head>
Btw, I haven't used the component on the frontend and was upto testing the module out.
The component, via the backend works beautifully, so I guess it's a frontend problem ?
(The scriptgator plugin has been set to enable JQuery at both ends).

Any other ideas ?
Many Thanks
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3058

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Yes, indeed, it's only a problem with your front-end template, not the back-end one.

I just installed and tested the scriptgator plugin but didn't have any conflict so I don't think the issue is there.

When I access your component menu:
Part of the message is hidden for the guests. Please log in or register to see it.
I can see that the javascript is added properly to the header.

Could you please add the AcyMailing module on an other page without any other module so we can see if it's a compatibility issue with an other module?

Also, could you please change your front-end template to the default one, that would enable us to determine if the problem is with your template or something else.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3059

  • Anonymous user
  • thewebguy's Avatar
  • Posts: 7
  • Karma: 0
I think I found what was causing the issue ? ...

I was displaying the module inside another module (in order to make use of the half yellow/white title format). I used the plugin 'Modules Anywhere' to achieve that, but alas this created an issue with the script needed to run the module correctly !

However, now when I fill in the details and subscribe something happens but I can't see the new subscriber in the admin - Am I missing something ?

Also, if you don't mind, would you have any suggestions (other than not using the method !) for getting the script to run correctly with the module in a module method ? - It's not vital, it just presents another challenge
Also, could you please change your front-end template to the default one, that would enable us to determine if the problem is with your template or something else
Do I still need to do the suggestion quoted ?
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3061

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Do I still need to do the suggestion quoted ?
You apparently found the issue so I don't need it.

I just subscribed to your website and apparently the process is working well, are you sure the user has not been added to the list of AcyMailing users? (maybe you had a filter selected or something like that which hide the new user)

You can edit your template and manually add our module js file in your header, that will do the job too.
In your case it will be:
<script type="text/javascript" src="/kukis/components/com_acymailing/js/acymailing_module.js"></script>
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3090

  • Anonymous user
  • thewebguy's Avatar
  • Posts: 7
  • Karma: 0
That's working beautifully now.

The subscription now works but the mootools options wont function. I can live with that and have the choice of reverting back to the regular module method. However, if you have any ideas I'd be most grateful but I don't want to push my luck !

Thank you for the help, your support has been most efficient. A definite 5-stars
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3092

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Using the scriptgator plugin you should be able to load mootools as well and that should do the job
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re: Location ? 10 years 8 months ago #3123

  • Anonymous user
  • thewebguy's Avatar
  • Posts: 7
  • Karma: 0
Just for your information ...

I haven't been able to get all the script to work in the module in module method. I've left them both on the Tapas pages until I decide which has the better look for the site ?

I expect I'll return to the issue and bully it into submission when I've completed more of the site.

Thanks Once Again
Cheers
Ernie
Please log in to post a reply
Time to create page: 0.072 seconds
Powered by Kunena Forum