×

info

Dear guests,
You are currently on the old forum we kept as a knowledge base. You will find the new community forum here
Welcome, Guest
Username: Password: Remember me
Keyword

TOPIC: [SOLVED] confirm your Subscription

[SOLVED] confirm your Subscription 10 years 9 months ago #15

  • Anonymous user
  • sbouloc's Avatar
  • Posts: 24
  • Karma: 0
Hello

When a user subscribes to the newsletter, he receives an email with the subjetc
(name), please confirm your Subscription
and this text:
Hello (name),

Click here to confirm your Subscription

My questions are:
1- where can I edit this? (subject and body of the confirmation mail)
2- Can I add the confirmation link if the readers mail client is set to 'no-html'? As for now, if the readers mail client is set to 'no-html' no url is displayed.

Thank you.
Attachments:
Last Edit: 10 years 9 months ago by Anonymous user.
Please log in to post a reply

Re:confirm your Subscription 10 years 9 months ago #16

  • Anonymous user
  • sbouloc's Avatar
  • Posts: 24
  • Karma: 0
Dont answer question 1, I just found the 'modify confirmation email' button.
Sorry.
Please log in to post a reply

Re:confirm your Subscription 10 years 9 months ago #17

  • Anonymous user
  • admin's Avatar
  • Posts: 41
  • Karma: 2
Hello,

I'm not sure I understand what you want to display for non-html e-mails.
Actually the receiver should see the confirmation link so he has to copy/paste it in his browser in order to confirm his subscription (for plain text version).
What would you exactly want to display?
Please log in to post a reply

Re:confirm your Subscription 10 years 9 months ago #29

  • Anonymous user
  • sbouloc's Avatar
  • Posts: 24
  • Karma: 0
It looks like most of the problems I had are just resolved now without any intervention. :huh: Could this be caused by the local internet provider(monopolistic and not very efficient usualy)? Anyway, I still have the problem with the no-html version of the confirmation mail. It displays the text but no url for the confirmation (see screenshot). Also, special characters are not displayed properly (french language). I guess I have to convert the file in utf8 but I have no idea which file I should modify.

HTML version works fine.

Thank you.

confirmation_no_html.jpg
Last Edit: 10 years 9 months ago by Anonymous user.
Please log in to post a reply

Re:confirm your Subscription 10 years 9 months ago #31

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
That's definitely a very clear bug report, thank you for that.
I will have a look at it immediately and let you know asap.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:confirm your Subscription 10 years 9 months ago #32

  • Anonymous user
  • sbouloc's Avatar
  • Posts: 24
  • Karma: 0
Thank you John.
Please log in to post a reply

Re:confirm your Subscription 10 years 9 months ago #35

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Hello,

You will have to tell me more about the problem.
I just tried on our test environments and it's working properly.
Then I tried on your own website and get the result :

Bonjour tempadmin,

Veuillez confirmer votre inscription à la newsletter Sicom en cliquant sur le lien suivant:

Confirmation ( www.sicom-pacifique.com//index.php?optio...id=11&key=xxxxxxxxxx )

Si vous ne vous êtes pas inscrit(e) ou si vous avez changé d'avis, ne faites rien; Votre inscription ne sera pas prise en compte.

Could you please tell me how you tested to have the unexpected result?
I used GMail for my tests and that's maybe the reason I see the special characters properly. Could you tell me what mail client do you use?
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Last Edit: 10 years 9 months ago by Anonymous user.
Please log in to post a reply

Re:confirm your Subscription 10 years 9 months ago #36

  • Anonymous user
  • sbouloc's Avatar
  • Posts: 24
  • Karma: 0
I am using squiremail, webmail installed on my hosting. I have tried again (test confirmation mai in the backend) and got the same result as previously. I will try with my gmail account and see how it does.
Please log in to post a reply

Re:confirm your Subscription 10 years 9 months ago #37

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Ho I see!
So that's an easy one :)

If you subscribe with a "receive html : No" account, then AcyMailing will send the text version (only the text version of the e-mail).
But if you subscribe with "receive html : Yes", AcyMailing will send the HTML Version + the text version (depending on your configuration!).

In your case, AcyMailing was sending the HTML version ONLY and so your own mail system generated a text version based on the HTML one, that's why the link was removed.

I changed your AcyMailing configuration to "Send Multiple Part : Yes" (in the mail configuration tab), and now AcyMailing sends both versions so your mail server directly opens the plain text one and doesn't generate a text version from the html version.
So now the characters are all good and you can see the link properly.

I'm not sure I want to modify the default value of this option because in some server don't accept to send multiple part e-mails (we had some issues with Chinese servers) but in your case, you can safely keep this option turned On and so both versions of the e-mail will be sent in the same time and the mail client will open the right one directly.

Best Regards,
John
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:confirm your Subscription 10 years 9 months ago #38

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
I just changed the default value during the install process.
You can forget about this issue for your future installations.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:confirm your Subscription 10 years 9 months ago #39

  • Anonymous user
  • sbouloc's Avatar
  • Posts: 24
  • Karma: 0
Thanks a lot for your help John and Adrien.
Please log in to post a reply
Time to create page: 0.280 seconds
Powered by Kunena Forum