×

info

Dear guests,
You are currently on the old forum we kept as a knowledge base. You will find the new community forum here
Welcome, Guest
Username: Password: Remember me
Keyword

TOPIC: Including module using curl

Including module using curl 10 years 9 months ago #1393

  • Anonymous user
  • Marius's Avatar
  • Posts: 4
  • Karma: 0
Hi,

I try to include a module in my newsletter. When I click on "Test" in the plugin properties, the plugin says "Error. Please make sure the function file_get_contents is enabled on your website". even though I have set "allow_url_fopen = On" in my php.ini file.

The plugin also says "The cURL function is apparently enabled on your server so you should select the cURL option". I did that but the plugin is not working either. Wht can I do?

Thanks
Please log in to post a reply

Re: Including module using curl 10 years 9 months ago #1394

  • Anonymous user
  • robert's Avatar
  • Posts: 138
  • Karma: 15
Hi,

From what I can see in the code, this test on file_get_contents is done regardless of the curl setting, so when you clcik on test, even if you have curl set in the plugin it will try the file_get_contents.

Is your plugin published ? If you add a module tag in a new newsletter and that you click on replace tags, I suppose that the module tag is not replaced by the module html, is that right ?

Do you have any error at that time ? If you activate "display_errors" in your php.ini maybe you wil get an error when you click on the replace tag button and that you have a module tag to be replaced in your newsletter. That would give us more information. It could be that your hosting provider is forbidding outgoing connections from your server. So you could try to ask them about that.

Regards,

Robert
With HikaShop, create your online Joomla shop easily.
Please log in to post a reply

Re: Including module using curl 10 years 9 months ago #1396

  • Anonymous user
  • Marius's Avatar
  • Posts: 4
  • Karma: 0
Ok, it works now. I'm working with a live site and a password protected(!) development site. It was because of the password protection...
Please log in to post a reply
Time to create page: 0.055 seconds
Powered by Kunena Forum