×

info

Dear guests,
You are currently on the old forum we kept as a knowledge base. You will find the new community forum here
Welcome, Guest
Username: Password: Remember me
Keyword

TOPIC: Can't make "From Name" work

Can't make "From Name" work 10 years 10 months ago #1386

  • Anonymous user
  • pnbnsv's Avatar
  • Posts: 7
  • Karma: 0
Hi,

I am trying to send a newsletter with the Add Names option enabled. But when this option is enabled the e-mails aren't received by the recipients. I am trying with one gmail and one hotmail recipient accounts.

When I send a test in the Configuration section, even with the Add Names enabled, the e-mail reaches the recipient exactly the way I wanted.

So, if it works with the test why it isn't working when the "real" newsletter is sent?

Can someone help with this?

Thanks,

Paulo
Please log in to post a reply

Re:Can't make "From Name" work 10 years 9 months ago #1395

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Which version of AcyMailing do you use? (if you don't use 1.1.1 please update and that may fix your problem)

The differences with the test and the real Newsletter are:
-> The e-mail is sent in HTML instead of a plain text version (but that should not change anything on the fact the names are not working)
-> The recipient of the e-mail are different.

Can you send a Newsletter to the same user you sent a test?
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:Can't make "From Name" work 10 years 9 months ago #1409

  • Anonymous user
  • pnbnsv's Avatar
  • Posts: 7
  • Karma: 0
Hi, thanks for the reply. Version is 1.1.1

I sent the test and the newsletter to the same users.

The test works perfectly with the "From name" correct and the "Add names" option enabled. But the newsletter can be sent, to gmail and hotmail accounts (for example) only if I disable "Add names" option.

Tried to send it to a private domain account and it worked (our domain: @partners4life.pt)

Please find attached a file with the returned error from the mail server.

Regards,

Paulo

Attachment error.txt not found

Attachments:
Please log in to post a reply

Re:Can't make "From Name" work 10 years 9 months ago #1416

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Hello Paulo,

I'm afraid I don't have any other ideas for now than asking you to turn OFF the "add names" option.
I'm not sure why you can send it to some addresses and not to others, it's probably linked to your mail server as well.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:Can't make "From Name" work 10 years 9 months ago #1421

  • Anonymous user
  • pnbnsv's Avatar
  • Posts: 7
  • Karma: 0
I think it is something to do with the sintaxe. The error refers to an e-mail address without the ">" in the end. Isn't it related to the way it is produced by your component?

Thanks for the help.

Paulo
Please log in to post a reply

Re:Can't make "From Name" work 10 years 9 months ago #1436

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
No, I don't think so, we are working with the phpMailer library which handles that automatically (the same is used by Joomla)
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:Can't make "From Name" work 10 years 9 months ago #1447

  • Anonymous user
  • pnbnsv's Avatar
  • Posts: 7
  • Karma: 0
I just contacted my mail server operator and they say there is no restriction to names in the server side. They say that the problem with those e-mails that gave an error was the > character that wasn´t at the end of the e-mail address. Any ideas?

Thanks,
Paulo
Please log in to post a reply

Re:Can't make "From Name" work 10 years 9 months ago #1448

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
The missing > is only on the answer created by your own mail server.
The e-mail sent using AcyMailing contains the < and > for each e-mail address.

This header is created by your own mail server:
MailEnable: Message could not be delivered to some recipients.
The following recipient(s) could not be reached:

Recipient: [SMTP:Your name <This email address is being protected from spambots. You need JavaScript enabled to view it.]
Reason: Remote SMTP Server Returned: 501 Invalid Address


But this header is created by AcyMailing:
Subject: Testar
To: Your name <This email address is being protected from spambots. You need JavaScript enabled to view it.>
Date: Mon, 21 Dec 2009 15:20:10 +0000
Return-Path: This email address is being protected from spambots. You need JavaScript enabled to view it.
From: Your name 2 <This email address is being protected from spambots. You need JavaScript enabled to view it.>
Reply-To: Your name 2 <This email address is being protected from spambots. You need JavaScript enabled to view it.>
Message-ID: <This email address is being protected from spambots. You need JavaScript enabled to view it.>
X-Priority: 3
X-Mailer: www.yyy.pt/
X-Mailid: 7
X-Subid: 2
MIME-Version: 1.0

So the problem is definitely not because of the missing > as its only missing on the reply created by your own mail server!

Please let me know if they have an other explanation, I would be happy to modify our program to be compliant with all mail servers but I need more infos about the error...

Could you please try to disable the "send multiple part" option?
Just to give it a try... but I'm not convinced it will change anything.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:Can't make "From Name" work 10 years 9 months ago #1455

  • Anonymous user
  • pnbnsv's Avatar
  • Posts: 7
  • Karma: 0
I've disabled multiple part but didn't work as well. That's strange because it seems only to happen with gmail and hotmail domains.
Please log in to post a reply

Re:Can't make "From Name" work 10 years 9 months ago #1464

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
We added the option "add Names" because we knew sometimes it could cause issues with some mail servers.
In your case I'm afraid I don't have other ideas to make it work but turning it off.

My last idea:
Maybe adding quotes around the name solve the problem?

Could you please modify the name of your user and add quotes around it to see if that does the job?
If so, we could automatically add quotes around the name of the receiver during the send process...
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:Can't make "From Name" work 10 years 9 months ago #1473

  • Anonymous user
  • pnbnsv's Avatar
  • Posts: 7
  • Karma: 0
It didn't work. But I discovered that if the name is removed from the "Name" field it works normally. The "From name" text is displayed in the recipient computer, but not its own name. So, it means that I can send a newsletter that identifies us, as the sender, but doesn't personalize the e-mail header with the recipient name.

Is this new to you?
Please log in to post a reply

Re:Can't make "From Name" work 10 years 9 months ago #1478

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
We know some mail server can not send e-mails if we add the name of the user but reporting the error using a bounce e-mail is something new for us.
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:Can't make "From Name" work 10 years 8 months ago #2996

  • Anonymous user
  • pnbnsv's Avatar
  • Posts: 7
  • Karma: 0
Hi, just to inform you that I am finding now that the use of the field name only works with e-mails of our own domain. I thought that it was only with domains like gmail or hotmail, but after all it is with any e-mail.
Please log in to post a reply
Time to create page: 0.063 seconds
Powered by Kunena Forum