×

info

Dear guests,
You are currently on the old forum we kept as a knowledge base. You will find the new community forum here
Welcome, Guest
Username: Password: Remember me
Keyword

TOPIC: [SOLVED]HTML email template-background image not showing in sent emails

[SOLVED]HTML email template-background image not showing in sent emails 10 years 9 months ago #1030

  • Anonymous user
  • Attros's Avatar
  • Posts: 9
  • Karma: 0
Hello!
I have a strange problem with my html template. I made a new template for a special mail and in this template I'm using a background image with the following inline css code:
<div style="font-family: Segoe Script; font-size: 14px; color: #662100; font-weight: bold; background-image: url(http://www.online-konyvek.info/marketing/old_paper_back_3.png); background-repeat: repeat-y; width: 600px;"><img src="http://www.online-konyvek.info/marketing/Olde_Books_3.png" height="400" width="600" /></div>
Well, in the preview or when I made a new newsletter and I choose the template, the template is showing correctly but when I send the newsletter the mail had no background.
In the preview it's look like here:


But when is sent it's like here as you can see:


I had checked with Hotmail, with Gmail and with my mail server with Horde. Yahoo simply is not accepting the emails, I had sent 3 test emails and none of emails had not arrived. They are not received physically, I mean are not in the Spam folder. In the rest all are showing without background.

Related to my config in Acyba: the images are not embedded in the emails, are only linked. Emails are sent in multipart mode.

I'll made something wrong?
PLease help me to resolve this issue, it's relative urgent for the production site.

My config:
latest Joomla 1.5
AcyMailing Enterprise v 1.1.1
Last Edit: 10 years 9 months ago by Anonymous user.
Please log in to post a reply

Re:HTML email template-background image not showing in sent emails 10 years 9 months ago #1031

  • Anonymous user
  • john's Avatar
  • Posts: 10494
  • Thank you received: 2
  • Karma: 242
Replace your div by a table with one line/column and your background image should be displayed properly.
<table style="font-family: Segoe Script; font-size: 14px; color: #662100; font-weight: bold; background-image: url(http://www.online-konyvek.info/marketing/old_paper_back_3.png); background-repeat: repeat-y; width: 600px;">
<tr><td>
<img src="http://www.online- konyvek.info/marketing/Olde_Books_3.png" height="400" width="600" />
</td></tr></table>
Please have a look at our official documentation before posting a new message!

If you use AcyMailing, please post a rating and a review at the Joomla! Extensions Directory.
Please log in to post a reply

Re:HTML email template-background image not showing in sent emails 10 years 9 months ago #1041

  • Anonymous user
  • Attros's Avatar
  • Posts: 9
  • Karma: 0
Hi!
With some minor CSS styling refinements the solution works 100%! Checked with Gmail, Hotmail, my private server and with Yahoo (it was the most problematic).
So thank you so for the quick reply and the right solution!
Thumbs up!
Best regards:
Attila
Please log in to post a reply
Time to create page: 0.069 seconds
Powered by Kunena Forum