×

info

Dear guests,
You are currently on the old forum we kept as a knowledge base. You will find the new community forum here
Welcome, Guest
Username: Password: Remember me
Keyword
Please report any bugs or errors here.

TOPIC: Text messages not reaching provider API after upgrade

Text messages not reaching provider API after upgrade 2 years 7 months ago #107430

  • Anonymous user
  • cliffvt's Avatar
  • Posts: 53
  • Karma: 0
Guys

We have been using AcySMSM for years with proviuder TXTLOCAL in the UK with no issues - After upgrading to the latest version it seems SMS messages are showing as successfully sent in AcySMS but it never reaches the provider and no messages are actually sent or delivered.

They say there is no issue their side so now I am stumped..

Any ideas why this could happen please?

Cliff
Please log in to post a reply

Text messages not reaching provider API after upgrade 2 years 7 months ago #107434

  • Alexandre
  • Alexandre's Avatar
  • Posts: 2462
  • Karma: 67
Hi,

Do they have changed their API recently ?
Are the SMS sent from AcySMS displayed in the TXTLOCAL backend ?
Please log in to post a reply

Text messages not reaching provider API after upgrade 2 years 7 months ago #107435

  • Anonymous user
  • cliffvt's Avatar
  • Posts: 53
  • Karma: 0
Alexandre

No they have not and no the text messages dont even seem to reach them. I am on the phone wth them onw and they want me to add some debug code to the end of the string - where can I add that please? I'm looking at the textlocal gateway php file but its a bit cnfusing :)

The idea is if we add the debug command, then they will be able to see what happens when AcySMS communicates with their API and run a debug...

Cheers

Cliff
Please log in to post a reply

Text messages not reaching provider API after upgrade 2 years 7 months ago #107436

  • Anonymous user
  • cliffvt's Avatar
  • Posts: 53
  • Karma: 0
OK Textlocal have dome some digging and heres the issue:

1. Preiously when we sent API messages, you passed the API hash - this shows on all the successful messages up to December before I upgraded

2. Since the upgrade - there has been no API has passed, therefore the messages were not accepted, although in AcySMS backend it shows successfully sent

3. I added our Textlocal account password to the TextLocal "Sender profile" and then sent them a test message, and it now works fine

So it seems as if the upgrade messed with the hash keys somehow.

I have our Textlocal hash key - how can we fix this to work with the has key again please?

Thanks a lot
Please log in to post a reply
Time to create page: 0.078 seconds
Powered by Kunena Forum